any preference in naming for an assertion that an amount has the expected number of digits after the decimal? i'm thinking "assert_scale", "assert_fractional_part_size", "assert_mantissa_length", "assert_decimal_places", etc.
going with "assert_scale" and an explanatory docstring for now
phantomcircuit, to fix link errors you may need to move blockfilter.cpp from libbitcoin_server library to libbitcoin_util library in makefile
wallet isn't linked against libbitcoin_server to prevent wallet code from trying to access node global variables
but a lot of things in libbitcoin_server that are just utilities without server state don't really belong there